Upgrade SDK Version

Guide to upgrading sdk version for your operator

Backwards Compatibility when Upgrading Operator-sdk version

When upgrading your version of Operator-sdk, it is intended that post-1.0.0 minor versions (i.e. 1.y) are backwards compatible and strictly additive. Therefore, you only need to re-scaffold your operator with a newer version of Operator-SDK if you wish to take advantage of new features. If you do not wish to use new features, all that should be required is bumping the operator image dependency (if a Helm or Ansible operator) and rebuilding your operator image.


Backport Policy

v1.13.1

v1.13.0

v1.12.0

v1.11.0

v1.10.0

v1.9.0

v1.8.0

v1.7.1

v1.7.0

v1.6.0

v1.6.1

v1.5.0

v1.4.0

v1.3.0

v1.2.0

v1.1.0

v1.0.0

v0.19.0

v0.18.0

Operator SDK Version upgrade guide

A guide to upgrading the Operator SDK version for an existing operator project from v0.2.x all the way through to 0.17.x.

v0.0.x to v0.1.0

A guide to migrate an operator project built using Operator SDK v0.0.x to the project structure required by v0.1.0.